Requirements for FrangoPuzzle

FrangoPuzzle runs on iPads and iPhones.  

It requires  iOS 9.0 or later.

Feedback and Knowledge Base